Email deliverability issues
Incident Report for BitcoinVN
Resolved
This incident has been resolved.
Posted Oct 03, 2023 - 17:21 GMT+07:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2023 - 11:46 GMT+07:00
Investigating
We are currently experiencing issues delivering emails. We are in touch with our email provider to resolve this problem.
Posted Oct 03, 2023 - 10:55 GMT+07:00
This incident affected: External (mailgun Outbound Delivery).